SLR350Ni and OPENCPN

Comments

30 comments

  • Official comment
    Avatar
    Dimitris Vitoris

    Hi Rich,

    Please check if you're getting data now at your designated IP/port combinations locally. Remember to open up the assigned

    port number using the localhost address (127.0.0.1) on the PC running OpenCPN.

    Regards

     

    Comment actions Permalink
  • Avatar
    Richard Markowitz

    Hi Dimitris. Thanks for the response. I am using OPENCPN on both my PC and my laptop and I now have them working on both. I had to use the Marine Traffic Receiver Web Panel and go into Local Broadcast Settings. I then set up two destination hosts using the local IP address of my PC and laptop and just picked a separate port for each. Then in OPENCPN I put the IP address of the SLR350Ni. It didn't work right away. I tried to do a reboot using the MTUtility but that didn't seem to work. I had to remove power from the receiver and reboot that way. After a period of time I went back to look and OPENCPN was working. 

    Your suggestion of using 127.0.0.1 I believe is only valid if the receiver is connected to the PC thru USB, correct?

    Thanks,

    Rich

    0
    Comment actions Permalink
  • Avatar
    Dimitris Vitoris

    Basically both ways can work (receiver IP - localhost) since the data transfer is via UDP (connectionless). By the way all services are

    restarted twice per day so you can either wait a little while for changes to apply or (as you did) restart the SLR350Ni. Good job!

     

    Regards

     

    0
    Comment actions Permalink
  • Avatar
    Richard Markowitz

    Hi Dimitris. Thank you for that info. It now makes sense why OPENCPN didn't work as soon as I expected it to after making the connection in local broadcast settings. The only question still remaining is why the the the reboot using MTUtility didn't seem to work on more than one occasion. When I attempted to reboot, the MTUtility lost contact with the receiver and couldn't find it again using the scan function. I waited what seemed to be an appropriate amount of time for a reboot but still couldn't find the receiver. Once I removed power and then reconnected power all was good.

    Rich

    0
    Comment actions Permalink
  • Avatar
    Stefanie Loges

    HI Dimitri and Rich,

     

    Me running into the same problem. Can't figure how to set up the 350NI to make OpenCPN listen to the stream.

    Can you please provide some more detailed info on how to assign which IP address and Port number to the Local Broadcast Settings in the 350NI?

    I tried 127.0.0.1 with Port Number 10110 - copied that into OpenCPN. Updated and Reset the device, but nothing happens. I'm on a Macbook.

    The 350NI is hooked up to the internet via ethernet and the Macbook connects to the 350NI MT Webserver/Dashbord via WiFi.

    Any help much appreciated.

     

    Best regards, Stefanie

    0
    Comment actions Permalink
  • Avatar
    Stefanie Loges

    Cancel this. I've been able to make it work to my satisfaction. 

    1
    Comment actions Permalink
  • Avatar
    HECTOR DAVID POLO

    Hello, I am trying to use OpenCPN with SLR350Ni too.

    I need to know the port number to use with the IP address.

    Best regards,

    0
    Comment actions Permalink
  • Avatar
    Stefanie Loges

    Hector,

    you can use any port number you wish. Make sure its one above 1080. Common port number for AIS/WiFI systems is 10110.

    0
    Comment actions Permalink
  • Avatar
    Dimitris Vitoris

    Hi Hector,

    As Stefanie pointed out, you can pretty much use any port you like. Just make sure it does not conflict with any other service running on the destination PC. For more information, please take a look at the receiver's User's Manual found below:

    https://help.marinetraffic.com/hc/en-us/articles/227724587-Comar-SLR-350Ni

    Regards

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I'm also trying to get a SLR-350Ni to sand data to OpenCPN. What I have done so far:

    In MT AIS receiver utility confirmed my 350Ni is 192.168.1.73 (I'm using ethernet connection, not wifi).

    In browser, in address line entered that ip addr, I get 

    This site can’t be reached

    192.168.1.73 refused to connect

    I tried the wifi ip addr, 192.168.1.48, but wifi has always been flaky for me.

    Is there anything we can do to get the ethernet ip addr to connect?

    Do you have any more info on getting OpenCPN to get AIS data, besides that is in this thread and Quick Guide to SLR350Ni?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Ilias Rigopoulos

     Hello Norm

     

    Could you please try once more logging into your receiver's dashboard? It should be OK.

    Now about the OpenCPN setup, please follow the steps below:

    1. Create a new host destination at your receiver's Broadcast settings with your computer's IP address and a port of your choice.

    2. Go to OpenCPN -->Options -->Connection and Add a new connection

    3. At the new connection properties select "Network", as protocol select UDP, as an address add the localhost IP(127.0.0.1 ) and as data port add the port that you chose before.

    If you need any further assistance I remain at your disposal.

     

    Best regards

     

     

     

    1
    Comment actions Permalink
  • Avatar
    Norm Perron

    Whatever you did allowed me to get into the box, thanks. Once I got in, I logged on (root/root), created a new host destination, port 73, see below.

    In OpenCPN, created new connection, see below

    There are always around 12+ ais vessels in King Harbor. Even several minutes later, I saw no ais targets on OpenCPN. Then I tried a different dataport, 999 (both in MT utility & OpenCPN, no change. I also tried the ip addr of my box, 192.168.1.73, no change I then wanted to try the port # that has been referenced, 10110. I couldn't get back into MT utility. Got signon screen, root/root filled in, nothing happens if I click Sign In. Tried several times, including on different pc's. I then turned off the live SLR350Ni (hate doing that, but was desperate), once it came back up, still couldn't Sign On.

    It looks like it was something you did that allowed me to get into the box. Is there something else I can do?

    0
    Comment actions Permalink
  • Avatar
    Ilias Rigopoulos

    Hello Norm 

    At your receiver's broadcast service settings you have to add the IP of the computer where you have installed the OpenCPN and not the receiver's IP address.

    Try that one and let me know if it worked for you.

     

    Regards 

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    It's still not working, but looking like we're very close. I'm doing everything on 1 laptop. IPCONFIG says my IPv4 addr is 192.168.1.246. Here's my Broadcast settings

    Here is my OpenCPN connection

    My receiver is definitely online. King harbor has quite a few vessels at this time, some of them from my station.

    For the fun of it, I tried 127.0.0.1 as I like that one more--and understand that can be used instead of .1.246, still nothing:

    Can you see what I have wrong? Thanks

    0
    Comment actions Permalink
  • Avatar
    Ilias Rigopoulos

    Hi again Norm

     

    Please at the OpenCPN settings use the localhost address(127.0.0.1)

    After that reboot the receiver via the MTUtility in order to speed up the restart of the receiver's services which are automatically restarted twice a day. It should do the trick.

    Let me know about your progress 

    Regards

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I just did all that. After reboot, re-established OpenCPN connection. Still no ais vessels. Went back to http://192.168.1.73/login.html my receiver to be sure still configured with my laptop ip addr. Saw login screen with root/root, clicking Sign in does nothing.

    0
    Comment actions Permalink
  • Avatar
    Richard Markowitz

    Hi Norm. At one screenshot I'm looking at you have the laptop address in both the broadcast setting and the OpenCPN setting. That won't work. The broadcast setting needs the address of your laptop and OpenCPN needs the address of your receiver with the same port for both. I never could get it working using 127.0.0.1. You'll have to reboot after making changes.

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    It's still not working. Some issues are putting addr of slr350ni in browser gives me "This site can't be reached". When I mention this, I get a message back saying "try it again, should work now" and gets me thru that phase. Looks like someone does a reset or something, is there anything I can do to get past this point?

    Now, I get the receiver web panel, root/root are filled in. Clicking Sign In does nothing. Is there anything else I can try?

    A few times I have got past this point and got to Local Broadcast settings and add a destination addr and port number.

    I can easily get into OpenCPN, Options and Add a connection. I have tried the Reboot in ais receiver utility and wait 5 or so minutes until I can scan and see it.

    This thread seems to have lots of valuable info scattered in several posts. I'm thinking this may be a good time to create a document listing all steps along with examples. I made my 1st pass of a Word doc, which is copy/pasted below. Are these the correct steps? Thanks

    Connecting a Marine Traffic Comar SLR350Ni to OpenCPN on a Windows PC

    1. On PC running OpenCPN, Hit <Windows Key> then type CMD
    2. In the DOS box type “ipconfig”, note IPv4 address (like 192.168.1.83)
    3. Run the MarineTraffic AIS Receiver Utility, hit Scan then Scan, note IP address (whichever one is being used, either Ethernet or Wi-Fi (like 192.168.1.73)
    4. Open a browser, enter IP address of the SLR350Ni (like 192.168.1.73)
    5. Default username/password are root/root
    6. Click Settings (to the right of Dashboard) then Local Broadcast Settings
    7. In Destination Address enter IP of OpenCPN pc, like 192.168.1.83, Destination Port something like 10110, then Add
    8. In OpenCPN, click Options then Connections
    9. Click Add Connection, then Network then UDP
    10. For address use 127.0.0.1 [or is it 192.168.1.83 in my example???], for Dataport use Port selected above, like 10110, then OK
    11. Then in MTUtility, reboot the receiver in order to speed up the restart of the receiver’s services
    12. If all went well, about 5 minutes later you should see vessels heard from your receiver on OpenCPN
    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I finally got it working. Interesting, I got a private email from Ilias saying the micro-SD chip on the receiver may have corrupt software on it. He gave me instructions on how to re-load it. That solved that device perfectly. For the past few weeks I've been able to get OpenCPN to work perfectly on it. Thank you Ilias.

    I also run another MT station, 4337. I have tried the same procedure on it but don't see any targets in OpenCPN. Attached is a screen show with all the prevalent data. I got thru logging in with root/root and re-boot the receiver after making changes. Can anyone see anything wrong with what I tried?

    Since I finally got it working I updated what I think are the total list of instructions. If anyone sees any changes, please let me know.

    Connecting a Marine Traffic Comar SLR350Ni to OpenCPN on a Windows PC

    1. On PC running OpenCPN, Hit <Windows Key> then type CMD
    2. In the DOS box type “ipconfig”, note IPv4 address (like 192.168.1.83)
    3. Run the MarineTraffic AIS Receiver Utility, hit Scan then Scan, note IP address (whichever one is being used, either Ethernet or Wi-Fi (like 192.168.1.73)
    4. Open a browser, enter IP address of the SLR350Ni (like 192.168.1.73)
    5. Default username/password are root/root
    6. Click Settings (to the right of Dashboard) then Local Broadcast Settings
    7. In Destination Address enter IP of OpenCPN pc, like 192.168.1.83, Destination Port something like 10110, then Add
    8. In OpenCPN, click Options then Connections
    9. Click Add Connection, then Network then UDP
    10. For address use 127.0.0.1, for Dataport use Port selected above, like 10110, then OK
    11. Then in MTUtility, reboot the receiver in order to speed up the restart of the receiver’s services
    12. If all went well, a few minutes later you should see vessels heard from your receiver on OpenCPN
    0
    Comment actions Permalink
  • Avatar
    Ilias Rigopoulos

    Hello Norm

     

    These are the exact steps that you have to follow.

    Do not forget that in step 10 you have to choose also the protocol, which has to be UDP.

     

    Regards

     

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    In step 9, I did select UDP.

    More importantly, any idea why on station 4337 OpenCPN doesn't show targets? Do you think I need to re-load the software on SD chip? I would like to have a chip (2nd one) ready to swap in, would a 32 GB microSD work?

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    After re-loading the Comar software (on micro SD chip), station 4337 works great with openCPN, thanks for all your help.

    I also run station 4337 and have been trying for quite a while to run openCPN on it on a Comar SLR350Ni. I reloaded the SD software but still can't see targets on openCPN, though see targets on the Dashboard. Following the steps I think should work, I did screen shots.

    ipconfig shows laptop as ip 192.168.0.55
    AIS receiver util scan shows Comar ethernet ip is 192.168.0.78
    In the Local Broadcast Settings, I added a connection host 192.168.0.55, port 10110
    In openCPN Options Connections I created a new Network UDP address 127.0.0.1 dataport 10110

    Even after waiting several minutes, rebooting laptop, rebooting Comar, I don't see any targets in openCPN, but do see them in the Dashboard.

    Any ideas of something else I can try?
    Thanks


     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I had it working, displaying targets on OpenCPN has stopped. I'm conducting an AIS seminar in less than 2 weeks and really need to get the SLR350Ni displaying targets in OpenCPN. Here's the document I created in the past, so these are the steps I'm doing:

    1. On PC running OpenCPN, Hit <Windows Key> then type CMD
    2. In the DOS box type “ipconfig”, note IPv4 address (like 192.168.1.83) now 192.168.0.14
    3. Run the MarineTraffic AIS Receiver Utility, hit Scan then Scan, note IP address (whichever one is being used, either Ethernet or Wi-Fi (like 192.168.1.73) now 192.168.0.94
    4. Open a browser, enter IP address of the SLR350Ni (like 192.168.1.73) 192.168.0.94
    5. Default username/password are root/root
    6. Click Settings (to the right of Dashboard) then Local Broadcast Settings
    7. In Destination Address enter IP of OpenCPN pc, like 192.168.1.83, Destination Port something like 10110, then Add    now 192.168.0.14  and  10110
    8. In OpenCPN, click Options then Connections
    9. Click Add Connection, then Network then UDP
    10. For address use 127.0.0.1, for Dataport use Port selected above, like 10110, then OK now 10110
    11. Then in MTUtility, reboot the receiver in order to speed up the restart of the receiver’s services
    12. If all went well, a few minutes later you should see vessels heard from your receiver on OpenCPN

    Can anyone see anything wrong? Is there any other settings I can try (I'm not able to get a usb cable to the Comar)?

    Thanks, Norm

    0
    Comment actions Permalink
  • Avatar
    Dimitris Vitoris

    Hi Norm,

    It seems that your PC is not reachable by the receiver:

    Is it behind some kind of firewall? Is it connected to your router via WiFi instead of Ethernet?

    Regards

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    My laptop is not connected to this network at this time. I don't visit this site very often.

    While at this site, my laptop definitely was connected to the Comar. You can see from my prior screen shot I logged on (root/root) the Comar saw the Dashboard (along with targets this receiver can see). 

    I forgot to mention it yesterday I did a few Reboots in MT AIS Receiver Utility. I also unplugged the receiver for about 30 seconds. At this site I've got targets all the way to OpenCPN a few times. To get that working in the past, I re-loaded the software on the microSD chip. I have a spare 32GB chip so will re-load it with Etcher.

    0
    Comment actions Permalink
  • Avatar
    Dimitris Vitoris

    Do you plan getting back on site any time soon? I feel that's the most direct and reliable way to troubleshoot the issue.

    Cheers

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I will actually be there tomorrow roughly 1700 hours Los Angeles time. I plan to re-load the micro SD by then and can be online at that time.

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I'm back at the site that won't show targets in OpenCPN, still can't see them. I can see targets on the SLR350Ni at home, so know how to configure the receiver & OpenCPN. I initially had a problem seeing targets at home and it was recommended to re-load the software with Etcher. I did that and got targets. So, since that was a possible solution, I got a spare microSD chip and loaded the s/w on it. Bottom line, I've reloaded the s/w on it several times, rebooted receiver, re-configured Local Broadcast settings and that has not solved my problem at my yacht club. I've used my spare microSD that works perfectly at home at the club, still not working.

    I'm putting on an AIS seminar this Saturday so really would like to make it work at my yacht club. The fact that I can log on as root/root, see targets on the Dashboard convinced me that I'm connected to the receiver.

    If anyone knows something else to try, I would like to try. 

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Dimitris Vitoris

    Is the receiver powered up at the moment? I can't seem to be able to reach it via VPN.

    Cheers

     

    0
    Comment actions Permalink
  • Avatar
    Norm Perron

    I definitely left it on when I left yesterday. I always look to see targets on the Dashboard screen. That tells me it is powered up, antenna is working, and is connected to building Internet. The fact that my laptop is able to post messages on this forum (yesterday at the yacht club) tells me the building is on the Internet, so station should be online.  I guess I learned something important yesterday. Point browser to https://www.marinetraffic.com/en/ais/details/stations/4337 to be sure it actually says Online. A big part of the problem is I only have access to the building 0900-2100 hrs local (UTC-8). It appears there is no overlap with your tech support. Another part of the problem, it is minimum 45 minute drive in each direction to visit the club, only during business hours.

    I did NOT get an email saying the station was offline, so I assume it remained online. I did power it off several times to swap microSD chips, did soft re-boots. I always Scan to find it back on and on the network. I always logon root/root after reboot..

    Questions

    How many minutes on average does ONLINE or OFFLINE (in the above link) get displayed after that event actually occurs?

    Can we take this personal issue offline? It is not fair to others that subscribe to this thread to keep getting emails and this thread is way too cluttered to have anyone follow it.

    0
    Comment actions Permalink

Please sign in to leave a comment.